
North Arm Cove Website: Self-Guided Workshop

It is really quite straightforward to contribute to the Cove website and, as with all things, practice 
makes it even easier. But if you don't know (or have forgotten) where to start then, hopefully, 
working your way through this workshop document may give you a few pointers.

What is covered in this workshop?
1. Logging in   page 1

 2. Your Blog/Account page   page 2

  3. Adding an Article  page 3

   4. Adding an Event   page 6

    5. Adding a Photo   page 8

     6. Editing content page 10

      7. Adding a Profile Picture page 11

1. Logging in:

Before you can add anything to the website you do need to be logged in!

The Log in link can be found by clicking on the Menu on the right-hand side of every web page. 
The Log in link is at the bottom of the menu.

If you ever forget your password (which is so easy to do!) ….

Click on the Log in link.

Then click on Reset your password

Enter your username or email address in the box and then 

Click on the Submit button.

A link to reset your password will be sent to your email address usually within minutes.
(Check your spam folder if it doesn't seem to have arrived.)
Then follow the instructions to set yourself a new password.

Hint: When logging-in on your own computer (and not a shared or public computer)

Click on the “Remember Me” box. 

That way you won't have to login quite as often.

When you have logged in you will be able to examine some of the features of your “blog”...
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2. Your Blog/Account page

Once you have logged in, you will be taken to your “account” or “blog” page. This will contain a 
list of all articles and photos that you have posted on the website.

Hint: Clicking on yourname wherever you see it highlighted
will take you back to your blog page.

On the right side of your blog page you will see the Contribute to the Cove website & blogs link.

Clicking on this link will take you to the Add content page for adding Articles, Classifieds, Events 
or Photos to the website.

You will also see the Website help link – clicking on this link will take you to the Help on using 
the Cove website page.

Clicking on  or the logo on any web page returns you to the site's home page.

Above the title of your blog are three tabs: 

The View tab enables to view the content of that page.

The Edit tab takes you to a form where you can change such things as your password or email 
address, or add a profile picture.

The Newsletters tab takes you to a form where you can subscribe (or unsubscribe) to the This week 
in the Cove newsletter which is sent by email at the beginning of each week.

Hint: After editing your details, or subscribing to the newsletter, and saving any changes you have
made, you will need to click on the View tab to return to your blog page.

You will also see the link The Cove blogs on the bottom of your blog page. Clicking on this link 
will take you to all of the Cove blog entries, in chronological order, commencing with the most 
recent one. It also has a list of people with blogs on the website.

Over time, your blog page will also have “teasers” of the content that you create.

Teasers are: the title plus some words from the beginning of each of your articles, 
small versions of your photos, and the basic details of your events. 

Teasers also have links to the complete articles, larger photos and full details of events.

The next three sections of this workshop look at adding Articles, Events and Photos.
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3. Adding an Article

Hint: Before adding content it is a good idea to check out these items that can be found
 on the bottom of every web page:

 Disclaimer  Contributor Code of Conduct  and 

Note, before you can add content you must be logged in!

An Article is:  one or more paragraphs about a topic of your choice;
 a suitable title
 and, if you wish, an image. (Or up to 10 images which will then appear as a slideshow!)
  Plus just a little bit of housekeeping.

To add an article, click on the Contribute to the Cove website & blogs link on your blog 
page, or the Add content link at the bottom of the menu.

The Add content page will open, then click on the Article submission link and the following from 
will open:

Hint: On the right hand side you will see useful information that gives you help on entering your article.
Warning: Don’t navigate away from this page before you have saved what you have done!

The title is the most important item. Click inside the box and type away.

The text of your article box is where you enter the content of your article. You can paste content
from a word processor application into this box but formatting may need to be fixed up afterwards.

Hint: Select the text with your mouse and use the Tx button to remove unwanted formatting.

Adding an image?

Click on Choose files to find it on your computer and then select your file and click open in 

your browser to upload 
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Large images get scaled to a smaller size after uploading – but the maximum upload per image is 
5MB.

Image files can be png, gif, jpg or jpeg only.

After an image has been uploaded a thumbnail will appear with a title box and some extra buttons:

(If you have uploaded the wrong image, click on Remove and try again.)

The picture TITLE that you enter here will become the caption for the image.

Note that you must fill in any field with an asterisk next to its heading!

Hint: You can add further images and these will then display as a slideshow in the article.

You will see at least one pull-down menu which asks you to select a word to describe 
the type of article you have written. 
Choose the appropriate option from the list. (You can also choose -None- !)

Now you need to look down to near the bottom of the page where you will see:

Preview shows you the teaser and full versions of your article 
and gives you another chance to edit it.

Press Save and your article is immediately live on the website!
The teaser will appear on your blog.

If you don't want to Save what you have done, 
EITHER use your browser “back” arrow 
OR → to go back to the previous page, or 

→ click on Home or the site’s “logo” 
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Hint: If you have already saved your article but were just practising and now want to
delete the article you have just added, see part 6 of this workshop: 6. Editing content.

Your article (and teaser) will

→ include the date and time you first saved it and

→ have your user name highlighted as a link.

Hint: Any viewer who clicks on that link will be taken to your blog page.
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4. Adding an Event

Let people know what is happening (and when) by adding your events to the website.

Hint: It is usually a very good idea to also put an article about the event on the website! 
There you can provide more detail as well as have better tools for formatting.

(If you do have an article, copy its web address from your browser's address bar and paste or type it as
part of your Event description. The address should start with https://   )

To add an Event click on Contribute to the Cove website & blogs link on your blog page; or 
click on the Add content link at the bottom of the menu, then click on Event on the Add 
content page.

The Create Event form will open:

Adding an Event is pretty simple. 

Firstly add a title for your event in the Title box.

Then you put in the date, time and duration for your event using this field:

The first two boxes   are for the start date and time.

The next box   is for the finish time.

Instead of adding the finish time you can put a duration in this box .
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If the event is an all-day event just put in the date and click on the  box.

For an event that will be occurring regularly, you can use the box to put in 
the additional dates.  

If your event is broken into two or more different time periods, on the same day or on a later day, 

you can click on this button  to add additional time periods.

After putting in the date, time and duration, you need to add a brief description of the event in the 
description box. You should keep your description as short as possible. (You will see the Description Box 
has limited formatting tools.)

When you have finished, click on Save at the bottom of the page.

Congratulations, your event is now on the Cove calendar.

If you don't want to Save what you have done, then either use your browser “back” arrow  OR ...
→ scroll back to the top of the form and click on Home. 

Hint: If you have already saved but were just practising and now want to delete the
event you have just added, see part 6 of this workshop: 6. Editing content.

Hint: Clicking on Home on any page will take you to the home page.
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5. Adding a Photo

There is much to photograph in this beautiful part of the world. Let others see some of your photos 
by adding them to your blog and our website gallery.

 To add a photograph click on Contribute to the Cove website & blogs link on your blog 
page; or click on the Add content link at the bottom of the menu, then click on Photograph 
Submission on the Add content page.

The photo title becomes the caption for the photograph in the gallery.

Browse for your photograph on your computer and then click on open in your browser to upload
it.

 

Large images will be scaled to a smaller size after uploading – although the maximum upload per 
photo is 5MB.

You will also be asked to enter some Alternative text to be used by screen readers.

There are two extra required items for photos before you can click Save:

 The name of the photographer (Your name if that was you!)

and

 The date the photograph was taken (estimate it if you don’t know).
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When finished click Save and your photograph will be saved and added to the gallery and your 
blog.

If you don't want to Save what you have done, then either use your browser “back” arrow  OR ...
→ scroll back to the top of the form and click on Home. 

Hint: If you have already saved but were just practising and now want to delete the
photograph you have just added, see part 6 of this workshop: 6. Editing content.

The next part of this workshop looks at how to edit something that you have previously posted.
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6. Editing content you have placed on the website

Multiple links to each piece of content you have placed on the website will appear on your blog 
page. To access that content to edit or, if necessary, delete it:

On your blog page will be list of teasers of items you have published, in chronological order, with 
the latest item at the top. 

Click on the appropriate title to view that item.

Because it is an item that you created ,when you view that item you will also see 

some tabs that other people do not see: 

If you wish to edit or delete the item ...
Click on the Edit tab to open a “form” a lot like the one you used to create it.

Hint: You can also go directly to that form by clicking on the edit link beside any teaser of an
item that you had created. Only you and the Site Administrators can see that edit link.

You can then either

 make your changes to the item, scroll to the bottom and click Save OR

 if you wish to delete the item, scroll to the bottom and click Delete.

The final section of this workshop looks at adding a Profile Picture to your blog.
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7. Adding a Profile Picture

As well as adding articles, events and photos to your blog/account page, you can, if you wish, add a 
“profile picture”. This will appear near the top of your blog page.

On your blog page:

Click on the EDIT tab:

On the form that opens scroll down until you reach the section headed Profile Picture     

Browse for your photograph on your computer and then

Upload it.
    Large images will be scaled to a smaller size after uploading – 
    although the maximum upload is 5MB

A thumbnail version of the photograph will appear.

If it is not the right photograph,

click on Remove and choose another photo from your computer

If you are happy with the image you have loaded

Click Save

Your chosen Profile Picture should now appear above the teasers in your blog. Clicking on it will 
display the full-size version.

Hint: To return to your blog page without saving, click on the View tab

Thank you for your time and effort in going through this workshop.

We look forward to seeing your contributions on the North Arm Cove website.
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